Web Browser Compatibility

The On Line Police Report system is tested and supported for users of Netscape and Internet Explorer versions 5.x and higher.

The system may work for other browser versions and types, but will not for others. If you are using an older browser, and having trouble submitting an on line police report, you have the following options:

Last updated Sep 27, 2011